DOCUMENTATION AND WEB SUPPORT

Documentation Authors’ Guide

G. DeContreras
08-Jul-2003
## Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Revision</th>
<th>Description</th>
<th>Author</th>
</tr>
</thead>
<tbody>
<tr>
<td>07/08/03</td>
<td>1.0</td>
<td>Initial Version</td>
<td>G. DeContreras</td>
</tr>
<tr>
<td>05/26/05</td>
<td>1.1</td>
<td>Added css and script directory descriptions</td>
<td>G. DeContreras</td>
</tr>
</tbody>
</table>
Table of Contents

1. OVERVIEW OF ESD WEB ............................................................................................................ 4

1.1. PUBLISHING LOCATIONS........................................................................................................ 4


1.1.2. www-group: http://www-group.slac.stanford.edu/cdsoft/ ....................................................... 5

1.1.3. webmcc: http://webmcc.slac.stanford.edu/sw/ ................................................................ 5

2. ORGANIZATIONAL STRUCTURE .......................................................................................... 6

2.1. FUNCTIONAL FOLDERS ........................................................................................................... 6

2.1.1. Web Page Hierarchy reflects Folder Hierarchy ..................................................................... 6

2.2. MIRRORING TO LOCAL SERVER WITH WGET .......................................................................... 8

2.3. HOME PAGES ........................................................................................................................... 8


2.3.2. http://www.slac.stanford.edu/grp/cd/soft/detailed.html .......................................................... 8

3. CREATING A WEB PAGE ...................................................................................................... 9

3.1. WEB PAGE............................................................................................................................... 9

3.1.1. Choose a directory............................................................................................................... 9

3.1.2. To AFS directory using “mkpage” ......................................................................................... 9

3.1.3. To AFS directory, www-group or webmcc using Contribute.................................................. 9

3.1.4. To www-group or webmcc using FrontPage ........................................................................ 10

3.2. INDEX PAGE........................................................................................................................... 10

3.2.1. To AFS directory using “mkindexpage” ............................................................................... 10

3.2.2. To AFS directory, www-group or webmcc using Contribute................................................ 10

3.2.3. To www-group or webmcc using FrontPage ........................................................................ 11

4. CREATING A PROJECT ........................................................................................................... 12

4.1. ON AFS ..................................................................................................................................... 12

4.2. ON WWW-GROUP OR WEBMCC ............................................................................................ 12

5. PUBLISHING TOOLS ............................................................................................................... 13

5.1. MACROMEDIA CONTRIBUTE ................................................................................................ 13

5.1.1. Connection to AFS .............................................................................................................. 13

5.1.2. Contribute Connection to www-group .................................................................................. 15

5.1.3. Contribute Connection to webmcc .................................................................................... 16

5.1.4. Basic Page Editing with Contribute .................................................................................... 17

5.2. MICROSOFT FRONTPAGE ........................................................................................................ 17

6. MICROSOFT WORD SUPPORT ............................................................................................ 18

6.1. TEMPLATES ............................................................................................................................. 18

6.2. ADD TO TEMPLATE LIST ...................................................................................................... 18

6.3. HOW TO USE A TEMPLATE ................................................................................................ 18
1. Overview of ESD Web

1.1. Publishing Locations

<table>
<thead>
<tr>
<th></th>
<th>AFS</th>
<th>www-group</th>
<th>webmcc</th>
<th>webmcc mirror</th>
</tr>
</thead>
<tbody>
<tr>
<td>Platform</td>
<td>Unix</td>
<td>Windows</td>
<td>Windows</td>
<td>Windows</td>
</tr>
<tr>
<td>Homepage</td>
<td><a href="http://www.slac.stanford.edu/grp/cd/soft/">www.slac.stanford.edu/grp/cd/soft/</a></td>
<td>none</td>
<td>none</td>
<td>Mirrored from AFS, read-only</td>
</tr>
<tr>
<td>Directory</td>
<td>/afs/slac.stanford.edu/www/grp/cd/soft</td>
<td>\Web002\www-group\cdsoft\</td>
<td>\Webmcc\wwwroot\sw\</td>
<td>\Webmcc\wwwroot\swmirror\</td>
</tr>
<tr>
<td>Visibility</td>
<td>World (except if in the slaconly subdirectory)</td>
<td>World</td>
<td>Slac-only</td>
<td>Slac-only</td>
</tr>
<tr>
<td>Privileges to write</td>
<td>Membership of AFS group g-www:g-cd-soft. See member of AFS group g-www:owner-g-cd-soft (ronc).</td>
<td>Membership of NT group CDSOFT-WWW. See Ruth McDunn.</td>
<td>Membership of NT group CDSOFT-WWW. See Ruth McDunn.</td>
<td>None</td>
</tr>
<tr>
<td>Intended use and Content</td>
<td>All documentation associated with projects already in AFS plus new documentation for Unix projects</td>
<td>Public documents author wishes to publish on Windows server</td>
<td>Slac-only documents author wishes to publish on Windows server</td>
<td>Local copy of documentation located on AFS in case of disconnect from SLAC network</td>
</tr>
</tbody>
</table>

Table 1: Publishing locations used by the Software Group

The VMS Web server www-mcc.slac.stanford.edu will remain as is, but no new documentation should be added. Web documentation located on CD-Server1 (http://cd-server1.slac.stanford.edu) will be moved to webmcc. Any individual accounts located on CD-Server1 should be moved to AFS (http://www.slac.stanford.edu/~<username>), or the individual account Windows server (http://www-user.slac.stanford.edu/<username>).

1.1.1. AFS: http://www.slac.stanford.edu/grp/cd/soft/

When to use this site: This is the primary location for web-based documentation of the Software Group.

All documentation associated with projects already in AFS should be placed here. New documentation for Unix projects as well as projects in general should also be placed here. Users who are members of the AFS group g-www:g-cd-soft
have authoring privileges to this web location. Everyone in the ESD Software Group should have membership to this AFS Group. See a member of the AFS group www:owner-g-cd-soft if you are for some reason not in g-www:g-cd-soft.

1.1.2. **www-group: http://www-group.slac.stanford.edu/cdsoft/**

When to use this site: If you want to use WebDAV for publishing, or you want to publish Microsoft format files such as Word, Excel, etc., then use a directory on this site. Note that documentation on this server is publicly viewable. For WebDAV publishing to a SLAC-only server, use webmcc (see below).

This is a public Microsoft IIS server maintained by SCS. If we were to disconnect from the SLAC network, we would lose connectivity to this server. Currently there are no plans to mirror these documents to webmcc. On the SLAC network, the path to this site is `\Web002\www-group\cdsoft\`. Users who are members of the NT group CDSOFT-WWW have authoring privileges to this web location. Everyone in the ESD Software Group should have membership to this AFS Group.

1.1.3. **webmcc: http://webmcc.slac.stanford.edu/sw/**

When to use this site: If you want to use WebDAV for publishing, or you want to publish Microsoft format files to a server with SLAC-only visibility.

This is a SLAC-only Microsoft IIS server located in our IFZ (Internet-Free Zone) maintained by SCS, but physically located in MCC. On the SLAC network, the path to this site is `\Webmcc\wwwroot\sw\`. Users who are members of the NT group CDSOFT-WWW have authoring privileges to this web location. Everyone in the ESD Software Group should have membership to this AFS Group.
2. Organizational Structure

2.1. Functional Folders

Functional folders will be the default locations of documents on Unix, if there is no other project subdirectory in which they should be located, or before that project subdirectory exists.

All of the functional folders listed below will be available at the top level of each of the publishing locations listed in Section 1 above. Each of these functional folders shall also be created in each project and sub-project folder. In addition, a slaconly folder should be created in each project or sub-project functional folder. There is no slaconly folder at the root of $CD_WWW.

1. ug: User Guides--end-user guides
2. pg: Programmer Guides--developer guides
3. req: Requirements
4. design: Design documents
5. hw: Hardware
6. admin: Administrative project documentation (e.g. status reports, meeting minutes, etc.)
7. how-to: General how-to documentation
8. ioc: General IOC documentation
9. db: General database documentation
10. css: Cascading Style Sheets for Web pages
11. script: Client side scripts for use with Web pages

2.1.1. Web Page Hierarchy reflects Folder Hierarchy

All documentation should be placed in a top level functional folder or one of the functional folders for a specific project or sub-project. Create a hyperlink from the index.html page of the functional folder where your document resides to your document. Through the use of index pages, the Web page hierarchy will reflect the folder hierarchy. If your document is in a project or sub-project folder, then create a hyperlink from the Unix Home page to the index.html page of the project.
Detailed Home Page

Figure 1: Schematic showing 2 of the 9 functional folders for 2 projects
2.2. Mirroring to Local Server with Wget

All AFS documentation in the ESD Software documentation home directory (/afs/slac.stanford.edu/www/grp/cd/soft/) and its subdirectories are mirrored to our new Windows IIS server, physically located in our Computer Room, in a read-only “swmirror” directory, http://webmcc.slac.stanford.edu/swmirror/. Mirroring will occur on a daily basis (00:15) using GNU Wget (http://www.gnu.org/software/wget/wget.html), a free network utility used to retrieve files using HTTP, HTTPS and FTP. Wget translates absolute URLs to the local web server while it recursively mirrors the directories. The webmcc mirror is independent of the SLAC network. Therefore, documentation located on this server will be available in the event of a network disconnect. The Operations Group has been provided with the link to the public page (described below) which has been mirrored to this server.

2.3. Home Pages

ESD Software has two home pages as follows:


This is the public home page for Web documentation for the Software Engineering Group. This page is the root of the mirror located at http://webmcc.slac.stanford.edu/swmirror/index.html. Technically, all of our Web-based documentation must be navigable from this page.


This is a second home page which contains more technical detail and links to projects. Its intended audience are members of the Software Engineering Group. However, it is still publicly viewable from outside the SLAC domain and is mirrored to webmcc (as http://webmcc.slac.stanford.edu/swmirror/detailed.html).
3. Creating a Web Page

3.1. Web Page

The template for creating a new Web page is located at http://www.slac.stanford.edu/grp/cd/soft/stds/html/master.html. From AFS, this template can either be copied into the directory you wish to place your document, or you can use one of the Web publishing tools, Contribute or FrontPage.

3.1.1. Choose a directory

Choose a functional folder directory under your project folder for the document you want to create. The functional folder names are listed in 2.1 above. If the appropriate functional folder directory does not exist, create it now using the mkdir command. Or you can use the mkweb script, described in 4.1 below, to make functional folders complete with index pages on AFS.

3.1.2. To AFS directory using “mkpage”

There is a script available which you can run from the directory you wish to create a new page. Type the command plus your filename (and optionally the topic and title) at the prompt as follows:

>mkpage filename.html “topic” “title” (e.g. mkpage userguide.html “esdweb” “User Guide”)

The script mkpage does the following:

1. Checks if the filename already exists in the current directory, in which case you will be given an error message
2. Copies the master.html file into your current directory, inserting the topic and title you provided into the document

Always add a link to your page from the index page of the functional folder where your document is located.

3.1.3. To AFS directory, www-group or webmcc using Contribute

1. Set up your connection to the desired Web area (AFS, www-group or webmcc) per the instructions included in the “Publishing Tools” section below.
2. Browse to the page from which you would like to link your new page. Click on “Edit Page”. Then place your cursor where you would like to insert your link.
3. Go to Insert→Link (or right-click and choose “Insert Link”).
5. The template will open in a new window. Edit.
6. When you are ready to publish, click on “Publish”. You will be prompted for a filename, and you will also be able to choose the folder you wish to publish to within the ESD Web site.
7. Publish the page from which you have linked your document.
3.1.4. To www-group or webmcc using FrontPage

2. Click on File→Edit with Microsoft FrontPage.
3. In Front Page, click on File→Save As
4. Navigate to the folder in which to save the document, and change the filename.
5. When you have completed editing, click on File→Save.

3.2. Index Page

The template for creating a new Web index page is located at http://www.slac.stanford.edu/grp/cd/soft/stds/html/masterindex.html. From AFS, this index template can either be copied into the directory you wish to place your document, or you can use one of the Web publishing tools, Contribute or FrontPage.

3.2.1. To AFS directory using “mkindexpage”

There is a script available which you can run from the directory you wish to create a new index page. When you type the command plus your filename (and optionally the topic and title) at the prompt as follows:

> mkindexpage “topic” “title” (e.g. mkindexpage “esdweb” “User Guide”)

The script mkindexpage does the following:

1. Checks if a file with the name “index.html” already exists in the current directory, in which case you will be given an error message
2. Copies the masterindex.html file into your current directory with the filename “index.html”, and inserts the topic and title you provided into the document

If your index page is for a functional folder, remember to add a link to it from the project or subproject index page, as well as from the top level functional folder. If the index page is for a project “home” page, remember to add a link from the http://www.slac.stanford.edu/grp/cd/soft/detailed.html page.

3.2.2. To AFS directory, www-group or webmcc using Contribute

1. Set up your connection to the desired Web area (AFS, www-group or webmcc) per the instructions included in the “Publishing Tools” section below.
2. Browse to the page from which you would like to link your new page. Click on “Edit Page”. Then place your cursor where you would like to insert your link.
3. Go to Insert→Link (or right-click and choose “Insert Link”).
5. The template will open in a new window. Edit.
6. When you are ready to publish, click on “Publish”. You will be prompted for a filename, and you will also be able to choose the folder you wish to publish to within the ESD Web site.
7. Publish the page from which you have linked your document.
3.2.3. To www-group or webmcc using FrontPage

1. On www-group, open http://www-group.slac.stanford.edu/cdsoft/ using Microsoft Internet Explorer. There is no index page at this level, so you will see a folder list. On webmcc, you would open the page http://webmcc.slac.stanford.edu/sw/.

2. Click on File→Edit with Microsoft FrontPage. You will receive an error message that “The specified file or Web does not exist”. Click OK.

3. In Front Page, click on File→New→Page or Web

4. From the list on the right hand side of your screen, select “Page Templates”. Select the “General” tab, and select either “SLAC ESD Software WWW Page Template” or “SLAC ESD Software WWW Index Page Template”, at the bottom of the list.

5. When you have completed editing, click on File→Save As.

6. Browse to the folder you would like to place your document and change the File name.

7. Click on “Save”.

4. Creating a Project

4.1. On AFS

First, create your project directory in the /afs/slac.stanford.edu/grp/cd/soft/html/ directory. Or create your subproject directory. There is a script available which you can run from your project or subproject directory which creates functional subdirectories and index pages. When you type the command plus the project topic (and optionally the functional directories you do not wish to create) at the prompt as follows:

> mkweb topic [-n {pg, ug, req, design, hw, howto, db, ioc, admin, slaconly}] (e.g. mkweb "esdweb" --n db ioc)

The script mkweb does the following:
1. Creates the functional folders minus any you have specified not to be created
2. Creates index pages for each of your functional folders, inserting your topic

4.2. On www-group or webmcc

On either of the IIS Servers, you can create project folders using Web Folders and Front Page. Here’s how:

1. On www-group, open http://www-group.slac.stanford.edu/cdsoft/ using Microsoft Internet Explorer. There is no index page at this level, so you will see a folder list. On webmcc, you would open the page http://webmcc.slac.stanford.edu/sw/.

2. Go to File→Edit with Microsoft FrontPage. You will receive an error message that “The specified file or Web does not exist”. Click OK. Once you select the top level directory, you will be able to create a new folder by clicking on File→New→Folder.

3. The master.html and masterindex.html files are located in the stds directory. See Section 3, “Creating a Web Page”.

Alternatively, you can browse to either of these server locations using Windows Explorer and create folders directly. The locations are as follows:

www-group: \Web002\www-group\cdsoft\webmcc: \Webmcc\wwwroot\sw\
5. Publishing Tools

5.1. Macromedia Contribute

If you would like make updates to an existing page from your PC, there is an easy way to do it securely using a few tools:

- Macromedia Contribute: web editing tool
- Java Runtime Engine
- MindTerm: intercepts the FTP transaction and sends it securely over SSH (required for publishing to AFS only)

1. If you don’t have one already, download and install a Java Runtime Engine on your local PC from http://java.sun.com/j2se/1.4.1/download.html.
2. Download Macromedia Contribute (free 30-day trial, $79.95 per license) to your local PC from http://www.macromedia.com/cfusion/tdrc/index.cfm.

5.1.1. Connection to AFS

1. Download and install MindTerm (free) to your local PC from http://www.appgate.com/mindterm/download.php.
2. Launch MindTerm by clicking on mindterm.jar.
   a. SSH Server/Alias: flora.slac.stanford.edu or a specific flora server.
   b. If you chose a non-specific flora server, click ‘OK’ to the host identification warning, and ‘Yes’ to replace the identification of the host.
   c. Enter your Unix username and password.
   d. Under Plugins --> FTP to SFTP bridge, enter Listen address of 127.0.0.1 and Listen port of 21 (2121 for Unix clients). Click ‘Enable’.
   e. Go to File --> Save Settings.
3. Launch Contribute.
   a. Go to Edit --> My Connections. Click on ‘New’.
   b. Enter required information, including full URL of page. For the software engineering pages on AFS, it’s http://www.slac.stanford.edu/grp/cd/soft/.
   c. If you are asked for a folder to publish to, enter /afs/slac.stanford.edu/www/grp/cd/soft/.
d. When you get to the following prompt, select FTP, and enter 127.0.0.1 (127.0.0.1:2121 for Unix clients) for the name of your local FTP server.

e. Enter your Unix login name and password.

f. Choose ‘User’ at the ‘What group do you belong to?’ prompt.

g. When you have completed the Connection Wizard, Contribute will establish a connection with the page you have selected.
5.1.2. Contribute Connection to www-group

If you browse to a page and the web server in the URL is "www-group.slac.stanford.edu", you will be asked to establish a new connection when you click on "Edit Page".

1. When the Connection Wizard prompts you for the Web address, enter http://www-group.slac.stanford.edu/cdsoft/.
2. Enter the following information when prompted for additional web server information:
3. Select "No, I don't want to be the administrator." at the next prompt.

5.1.3. **Contribute Connection to webmcc**

If you browse to a page and the web server in the URL is "webmcc.slac.stanford.edu", you will be asked to establish a new connection when you click on "Edit Page".

1. When the Connection Wizard prompts you for the Web address, enter http://webmcc.slac.stanford.edu/sw/.

2. Enter the following information when prompted for additional web server information:
3. Select "No, I don't want to be the administrator." at the next prompt.

5.1.4. Basic Page Editing with Contribute

Click on ‘Edit Page’ to open page for editing. Edit directly on the page. Note that Contribute does not allow you to edit the html directly.

5.1.4.1. Importing Documents

1. Create a link on the page by typing the text for the link
2. Select the text, then click on Insert→Link→File on My Computer (or right-click the selected text and choose “Insert Link”, then “File on My Computer”)
3. Navigate to your document. If you are importing a Word or Excel document, Contribute will create a directory at the location of your page called "documents" where your document will be placed. If it is an HTML file, then it will place it in the same folder your page is located.
4. Once you have finished editing the page, click on ‘Publish’.

5.1.4.2. Templates for Software Group Web Pages

Note that there are templates for Software Group Web pages in Macromedia Contribute. Go to File→New Page, then select either the “master” or “masterindex” template from the Templates folder in the “ESD Software AFS” Web Site. When you publish, you will be prompted to choose the folder where you would like the document to be located.

5.2. Microsoft FrontPage

If you prefer to edit your Web pages with Microsoft Word or Front Page from your PC, there is an easy way to do this if your pages are located on the www-group or webmcc servers using Microsoft Web Folders, which uses WebDAV (Web-based Distributed Authoring and Versioning) technology (more information available at http://www.webdav.org/).

1. Open your Web page using Microsoft Internet Explorer
2. Choose File→Edit with Microsoft Front Page (or Microsoft Word, if the document was originally created using Microsoft Word)
3. Edit
4. Save
6. **Microsoft Word Support**

6.1. **Templates**

Microsoft Word templates (suffix .dot) for the ESD Software Engineering group are located at [http://www-group.slac.stanford.edu/cdsoft/stds/](http://www-group.slac.stanford.edu/cdsoft/stds/).

6.2. **Add to Template List**

The following are the steps required to add templates to the template list on your local computer:

1. Open the template you would like to add to your template list.
2. Click on File→Save As→Save As Type: Document Template (*.dot), and browse to: C:\Documents and Settings\{your username}\Application Data\Microsoft\Templates
3. Click Save.

6.3. **How to Use a Template**

To use a template from your template list:

1. Open the Microsoft Word application.
2. Click on File→New.
3. A frame will open on the right which lists types of new documents you can choose from. Under “New from template”, click on “General Templates…”
4. The template you added will be available under the “General” tab.